System Requirements

Minimum system requirements for accessing the Professional Skepticism eLearning Programme

 

System RequirementsWindows Vista (32 and 64 bit)
Windows 7 (32 and 64 bit)
Windows 8 (32 and 64 bit)
Mac OSX 10.7, 10.8, 10.9 &10.10
Browser Requirements
(latest browser releases supported)
IE 11, IE 10, IE 9, IE8
Safari (for Apple) 8, 7, & 6.
Firefox 32, 31
Chrome 37
Safari for Windows is unsupported.
Additional SoftwareJRE (Java) V7.
V6 for Chrome on Mac.
Adobe 11 is recommended.

 

Other Devices

  

iPadSupported with additional software install such as Adobe Reader.
Blackboard App
(Apple and Android)
An App is available, however it is not suggested to use this to undertake the module.  For best results you are recommend to use a desktop/laptop PC or Mac. Blackboard has some known compatibility issues with IE11.